金股网,有趣实用股票资讯网站!

最近更新文章排行

当前位置:首页 > 股票资讯 > 通达信主力动能PRO指标公式源码

通达信主力动能PRO指标公式源码

时间:2023-09-17 15:25:48 人气: 作者: 金股网

  dpo:CLOSE-REF(MA(CLOSE,20),10),LINETHICK2,COLORRED;

  MADPO:MA(DPO,6),LINETHICK1,COLORGREEN;

  O轴:0,LINETHICK1;

  上价:=(MA(C,1)+MA(C,3)+MA(C,5)+MA(C,7)+MA(C,9))/5;

  下价:=(MA(C,2)+MA(C,4)+MA(C,6)+MA(C,8)+MA(C,10))/5;

  中价:=MAX(EMA(上价,1)-EMA(下价,5),0)*200;

  CXHZB:=IF((H>C AND C>O) OR (H>O AND O>=C),C,H)+IF((L

  cci:=EMA((CXHZB-MA(CXHZB,36.0270012))/(0.015*AVEDEV(CXHZB,36.0270012)),2.0332),COLORGREEN;

  关注:=MA((CLOSE-OPEN)/REF(CLOSE,1),30);

  关注度:=MA(关注,3)*10000;

  STICKLINE(关注度>0,MADPO,0,7/3,0),COLORLIRED;

  A1:=(EMA(CLOSE,7)-EMA(CLOSE,21));

  B1:=EMA((0.668*REF(A1,1)+0.333*A1),1);

  短多:=IF(A1>=B1,A1,B1),LINETHICK2,COLORRED;

  短空:=IF(B1-A1,B1,A1),LINETHICK2,COLORGREEN;

  VR11:=(CLOSE+HIGH+LOW)/3;

  vr12:=EMA(VR11,10);

  VR13:=REF(VR12,1);

  VAR1:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));

  VAR2:=(REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

  VAR3:=(REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

  VAR4:=(REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

  VAR5:=(REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

  VAR6:=(REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

  VAR7:=(REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

  VAR8:=(REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

  VAR9:=(REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

  VARA:=(REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

  VARB:=(REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

  VARC:=(REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

  VARD:=(CLOSE

  VARE:=(REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

  VARF:=(REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

  VAR10:=(REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

  VAR11:=(REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

  VAR12:=(REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

  VAR13:=(REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

  VAR14:=(REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

  VAR15:=(REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

  VAR16:=(REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

  VAR17:=(REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

  VAR18:=(REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

  持股: IF(VR12>VR13 AND (VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18)=0,1,DRAWNULL), COLORFF00FF,NODRAW;

  观望:VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,COLORFFFF00,NODRAW;

  主拉:MA(((H+L+C)/3-LLV((H+L+C)/3,15))/(HHV((H+L+C)/3,15)-LLV((H+L+C)/3,15)),2)*100,COLOR000080,NODRAW;

  散线:100*(HHV(HIGH,55)-CLOSE)/(HHV(HIGH,55)-LLV(LOW,55)),COLORGREEN,NODRAW;

  强弱线:IF(C>MA(C,5),1,0)+IF(C>MA(C,13),1,0)+IF(C>MA(C,21),1,0)+IF(C>MA(C,34),1,0)+IF(C>MA(C,55),1,0)+IF(C>MA(C,89),1,0)+IF(C>MA(C,144),1,0)+IF(C>MA(C,233),1,0)+-3.8,COLORMAGENTA,NODRAW;

  STICKLINE(持股=1,MADPO,0,7/3,0),COLORRED;

  STICKLINE(关注度>0 AND 强弱线=4.2,MADPO,0,7/3,0),COLORFF00FF;

  STICKLINE(关注度>0 AND 观望=1,MADPO,0,7/3,0),COLOR555500;

  DIFF:=EMA(CLOSE,3)-EMA(CLOSE,8);

  动能B:=EMA(DIFF,5)*5;

  动能A:=((EMA(CLOSE,3)-EMA(CLOSE,8)))*5;

  STICKLINE(短多=短空 AND 动能A>动能B AND CCI>100,0,MADPO,1/3,0),COLORRED;

  STICKLINE(短多=短空 AND CCI>100 AND 观望<>1,0,MADPO,1/3,0),COLORRED;

  DRAWTEXT(crOSS(EMA(CLOSE,3)-EMA(SLOPE(CLOSE,18)*20+CLOSE,55)*1,0),0,'G'),COLORRED;

  DRAWTEXT(CROSS(0,EMA(CLOSE,3)-EMA(SLOPE(CLOSE,18)*20+CLOSE,55)*1),0,'S'),COLORBLUE;

  VR1:=AMOUNT/((HIGH-LOW)*2-Abs(CLOSE-OPEN));

  日买:=IF(CLOSE>OPEN,VR1*(HIGH-LOW),IF(CLOSE

  日卖:=-IF(CLOSE>OPEN,0-VR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE

  净:日买-日卖,COLORLIRED,NODRAW;

  STICKLINE(净>0,0,净/(日买+日卖)*MADPO,5/3,0),COLORYELLOW;

  STICKLINE(净<0 AND MADPO>0,0,ABS(净/(日买+日卖))*MADPO,5/3,0),COLORGREEN;

  STICKLINE(强弱线=4.2 AND 动能A>动能B AND 观望<>1,0,MADPO,3/3,0),COLORFF00FF;

  STICKLINE(主拉=100 AND 观望<>1,0,MADPO,2.5/3,0),COLORGRAY;

  STICKLINE(散线=0 AND 观望<>1,0,MADPO,0,0),COLORYELLOW;

  MA5:=MA(CLOSE,5),COLORRED;

  MA10:=MA(CLOSE,10),COLORYELLOW;

  MA20:=MA(CLOSE,20),COLORFF00FF;

  MA40:=MA(CLOSE,40),COLOR00FF00;

  MA60:=MA(C,60),COLOR888888;

  MA250:=MA(C,250),COLORFFCC66;

  月托:MA5>MA20 AND MA5>MA10 AND CROSS(MA10,MA20),NODRAW;

  季托:MA20>MA60 AND MA20>MA40 AND CROSS(MA40,MA60),NODRAW;

  日托:MA5>MA60 AND MA5>MA10 AND CROSS(MA10,MA60),NODRAW;

  DRAWTEXT(月托,0,'月托'),COLORBLUE;

  DRAWTEXT(季托,0.1,'季托'),COLORYELLOW;

  DRAWTEXT(日托,0.15,'日托'),COLORFF00FF;

  vol5:=MA(VOL,5);

  VOL10:=MA(VOL,10);

  VOL20:=MA(VOL,20);

  量托:VOL5>=VOL20 AND CROSS(VOL10,VOL20) AND REF(VOL10,1)

  DRAWTEXT(量托,0.2,'量托'),COLOR0099FF;

  AA:=BArslAST(MA40>MA60 AND (MA20=MA40 OR MA20>MA40));

  BB:=REF(COUNT(C

  CC:=CROSS(C,MA60) AND VOL>MA(VOL,5) AND (C-REF(C,1))/REF(C,1)*100>3;

  芙蓉出水:BB AND CC,NODRAW;

  DRAWTEXT(芙蓉出水,0.3,'芙蓉出水'),COLORFF00FF;

 

通达信主力动能PRO指标公式源码